Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 14, 2024 - 19:00 UTC
Scheduled
There will some server performance issues while our new backup system starts taking backups of servers. You may experience some rubber-banding and increased latency while these take place.
Posted Dec 13, 2024 - 23:35 UTC
This scheduled maintenance affected: Hubs/Proxy (EU Hub Servers, Proxy 1, Proxy 2), Game Servers (Terranova 2, DayZ, Craft of Exile 2), and Websites (Forums, CDN).